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1 Foreword
The SY6 safety module adds the Safe Torque Off (STO) and Safe Stop 1 (SS1) safety
functions (both described as standard in DIN EN 61800-5-2) to the SI6 series device types of
the 6th generation of STOBER drive controllers.

STO prevents a rotating magnetic field, needed for the operation of synchronous or
asynchronous motors, from being generated in a drive controller immediately once the safety
function has been activated. In the case of SS1-t, the switch-off happens after a configurable
amount of time.

For a combination consisting of a SI6 drive controller and SY6 safety module, STO and SS1
safety functions are activated over EtherCAT (FSoE).

SY6 is a fast and wear-free fully electronic solution. The safety module is designed so that
regular system tests that interrupt operation are eliminated. In practical terms, this means
increased availability of machines and systems. The often complex planning and documentation
of function tests are also eliminated.

Drive controllers with an integrated safety module can be used in systems with high safety
requirements up to SIL 3, PL e, category 4. Compliance with standard requirements is ensured
by an external testing institute as part of type testing.
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2 User information
This documentation provides all information on the intended use of the SI6 drive controller in
combination with the SY6 safety module.

2.1 Storage and transfer
As this documentation contains important information for handling the product safely and
efficiently, it must be stored in the immediate vicinity of the product until product disposal and be
accessible to qualified personnel at all times.

Also pass on this documentation if the product is transferred or sold to a third party.

2.2 Described product type
This documentation is binding for: 
SI6 drive controller in combination with the SY6 safety module and the DriveControlSuite
software V 6.2-E or higher and associated firmware V 6.2-E or higher.

2.3 Timeliness
Check whether this document is the most up-to-date version of the documentation. We provide
the latest document versions for our products for download on our website: 
http://www.stoeber.de/en/download.

2.4 Original language
The original language of this documentation is German; all other language versions are derived
from the original language.

2.5 Limitation of liability
This documentation was created taking into account the applicable standards and regulations
as well as the current state of technology.

STOBER shall assume no responsibility for damage resulting from failure to comply with the
documentation or from use that deviates from the intended use of the product. This is especially
true for damage caused by individual technical modifications to the product or projecting and
operation of the product by unqualified personnel.

http://www.stoeber.de/en/download
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2.6 Formatting conventions
Orientation guides in the form of signal words, symbols and special text markups are used to
emphasize specific information so that you are able identify it in this documentation quickly.

2.6.1 Use of symbols
Safety instructions are identified with the following symbols. They indicate special risks when
handling the product and are accompanied by relevant signal words that express the extent of
the risk. Furthermore, useful tips and recommendations for efficient, error-free operation are
specially highlighted.

ATTENTION!

Notice

This indicates that damage to property may occur

▪ if the stated precautionary measures are not taken.

CAUTION!

Caution

This word with a warning triangle indicates that minor personal injury may occur

▪ if the stated precautionary measures are not taken.

WARNING!

Warning

This word with a warning triangle means there may be a considerable risk of fatal injury

▪ if the stated precautionary measures are not taken.

DANGER!

Danger

This word with a warning triangle indicates that there is a considerable risk of fatal injury

▪ if the stated precautionary measures are not taken.

Information

Information indicates important information about the product or serves to emphasize a section
in the documentation that deserves special attention from the reader.
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2.6.2 Markup of text elements
Certain elements of the continuous text are distinguished as follows.

Quick DC-Link module Words or expressions with a special meaning

Detailed information Internal cross-reference

http://www.stoeber.de External cross-reference

Software and display indicators

The following formatting is used to identify the various information content of elements
referenced by the software interface or the drive controller display, as well as any user entries.

Main menu 
Settings

Window names, dialog names, page names or buttons,
combined proper nouns, functions referenced by the
interface

Select 
Referencing method A

Predefined entry

Save your 
<own IP address>

User-defined entry

EVENT 52: 
COMMUNICATION

Display indicators (status, messages, warnings, faults)
for status information referenced by the interface

Keyboard shortcuts and command sequences or paths are represented as follows.

[CTRL], [CTRL] +  [S] Key, shortcut

Table > Insert table Navigation to menus/submenus (path specification)

Interpretation of parameter identification

Parameter identification consists of the following elements, where short forms are also possible,
i.e. only specifying a coordinate or the combination of coordinate and name.

E50 Drive controller G6 0

Coordinate
Name

Version

Drive controller
generation/series

http://www.stoeber.de
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2.7 Program interfaces
The following chapter includes an overview of the most important software components.

2.7.1 DS6: Structure of the program interfaces
The DriveControlSuite commissioning software offers a graphic interface which you can use to
project, parameterize and start up your drive controller quickly and efficiently.

1

2

3

4

5 6

Fig. 1: DriveControlSuite – program interface

1 Project tree

2 Project menu

3 Workspace

4 Parameter view

5 Plausibility view

6 Output view
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2.7.2 TwinCAT 2: Structure of the program interface
In TwinCAT 2, you operate your EtherCAT system using the TwinCAT System Manager. The
following graphic shows the program elements relevant to this documentation.

Config -Mode

1 2

3

Fig. 2: TwinCAT 2 (TwinCAT System Manager) – program interface

1 Tree view

2 Main window

3 Status display (configuration, run, connection setup/timeout mode)
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2.7.3 TwinCAT 3: Structure of the program interface
In TwinCAT 3, you operate your EtherCAT system using TwinCAT XAE. The following graphic
shows the interface elements relevant to this documentation.

1

2

3

4

5 6

Fig. 3: TwinCAT 3 (TwinCAT XAE) – program interface

1 Solution explorer

2 Main window

3 Message view

4 Toolbox

5 Event display

6 Status display (configuration, run, connection setup/timeout mode)

2.8 Trademarks
The following names used in connection with the device, its optional equipment and its
accessories are trademarks or registered trademarks of other companies:

EtherCAT®,
Safety over EtherCAT®,
TwinCAT®

EtherCAT®, Safety over EtherCAT® and TwinCAT® are registered
trademarks of patented technologies licensed by Beckhoff
Automation GmbH, Verl, Germany.

All other trademarks not listed here are the property of their respective owners.

Products that are registered as trademarks are not specially indicated in this documentation.
Existing property rights (patents, trademarks, protection of utility models) are to be observed.



3 | General safety instructions STOBER

12

06
/2

01
7 

| I
D

 4
42

74
4.

01

3 General safety instructions
There are risks associated with the product described in this documentation that can be
prevented by complying with the described warning and safety instructions as well as the
included technical rules and regulations.

3.1 Standards
The following European directives and standards are relevant to the product specified in this
documentation:

§ DIN EN ISO 13849-1:2016

§ DIN EN ISO 13849-2:2013

§ IEC 61800-5-2:2016 (basis for the revision of DIN EN 61800-5-2:2008)

§ DIN EN 61508-x:2011

§ DIN EN 60204-1:2007

§ DIN EN 62061:2016

§ IEC 61784-3:2010

Subsequent references to the standards do not specify the respective year in order to improve
readability.

3.2 Qualified personnel
In order to be able to perform the tasks described in this documentation, the persons instructed
to perform them must have the appropriate professional qualification and be able to assess the
risks and residual hazards when handling the products. For this reason, all work on the products
as well as their operation and disposal may be performed only by professionally qualified
personnel.

Qualified personal are persons who have acquired authorization to perform these tasks either
through training to become a specialist and/or instruction by specialists.

Furthermore, valid regulations, legal requirements, applicable basic rules, this documentation
and the safety instructions included in it must be carefully read, understood and observed.
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3.3 Intended use
The SY6 safety module can be combined with STOBER drive controllers of the SI6 series in
sizes 0 – 3.

If a drive controller with the integrated SY6 safety module is used in a safety-related application,
the safety module must be activated by a safety relay or a safety controller.

DANGER!

Electrical voltage! Risk of fatal injury due to electric shock!

An active STO safety function only means that generation of the rotating magnetic field at the
motor has been interrupted. The motor may still be energized with dangerous high voltages.

▪ Make sure that persons cannot come into contact with conductive parts.

▪ If the supply voltage must be switched off, observe the requirements of DIN EN 60204-1.

Improper use

The safety module may not be operated outside of the drive controller or operated not in
compliance with the applicable technical specifications.

Information

An emergency off in accordance with DIN EN 60204-1 is not possible with the SY6 safety
module! 
Observe this standard regarding the difference between emergency off and emergency stop
in conjunction with Safe Torque Off.

Modification

As the user, you may not make any technical or electrical modifications to the SY6 safety
module. Any removal of the module from the drive controller as well as any attempt at repair or
replacement is prohibited.

Maintenance

The safety module does not require maintenance.

Product life span

A drive controller with integrated safety module must be taken out of operation 20 years after
the production date. The production date of the drive controller is found on the accompanying
nameplate.
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4 SY6 safety module
The SY6 safety module adds the STO (Safe Torque Off) and SS1 (Safe Stop 1) safety functions
to the SI6 drive controller. The module prevents the formation of a rotating magnetic field during
the power output stage of the drive controller and, in the event of an error or by external
request, switches the drive controller to the STO state immediately or after a time delay (SS1-t).

SY6 – Features and certifications

§ Possible safety functions:

• Safe Torque Off – STO in accordance with DIN EN 61800-5-2

• Stop category 0 in accordance with DIN EN 60204-1

• Safe Stop 1 – SS1 in accordance with DIN EN 61800-5-2

• Stop category 1 in accordance with DIN EN 60204-1

§ Activation of the safety functions using Safety over EtherCAT (FSoE)

§ STO switch-off time: < 50 ms

§ Wear-free

Certifications in accordance with DIN EN 61800-5-2 and DIN EN ISO 13849-1:

§ Safety Integrity Level  (SIL) 3

§ Performance Level  (PL) e

§ Category 4
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5 System setup and function
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Fig. 4: Components of the FSoE-based safety concept

System components

Central components of the FSoE-based safety concept are:

§ SI6 drive controller with integrated SY6 safety module
... for implementing the STO and SS1-t safety functions

§ Controller (PLC) with integrated EtherCAT master
-... for organizing all network communication

§ Bus coupler (EtherCAT coupler)
... as a connector between the controller and safety controller; the bus coupler passes
messages from the safety controller to the EtherCAT master

§ Safety controller (S-PLC) with integrated FSoE master
... for FSoE communication and logic gate links between FSoE nodes; the safety controller
includes certified safety function modules that can be configured to the specific application
using suitable automation software (e.g. TwinCAT)

§ Safety terminals with digital fail-safe inputs and outputs
... for the connection of 24 VDC safety sensors such as emergency stop or position switches,
light barriers, pressure mats etc.

§ FSoE protocol
... for the transmission of safety-related data

§ EtherCAT
... as the underlying fieldbus system
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Function

The control unit of the drive controller generates pulse patterns (PWM) to produce a rotating
magnetic field at the IGBT module in the power output stage. This rotating magnetic field is
necessary for operating synchronous and asynchronous motors.

If the safety function is not active, the SY6 safety module enables rotating magnetic field
generation in the power unit; the connected motor can create a rotating magnetic field. If the
safety function is active, SY6 disables the generation of the rotating magnetic field in the power
output stage and the drive controller cannot generate any torque in the connected motor.

The SY6 safety module implements a FSoE slave. It exchanges control and status information
with the FSoE master via the EtherCAT master in accordance with the black channel principle.
The slave extracts the safety-related data, checks it for plausibility and enables or disables the
two safety channels in the power unit.

The STO and SS1-t safety functions relate to the device and are not axis-specific. On double-
axis controllers, both axes are brought to a safe state at the same time. 
An activated SS1 cannot be interrupted.

WARNING!

Increased overrun distance! Residual motion!

The safety module cannot prevent a failure of the functional part of the drive controller (e.g. 
during a controlled shut-down) while the SS1-t safety function is triggered. This may result in 
an increased overrun distance.

In the event of an error in the power unit of the drive controller, static energization of the motor
is possible despite active STO. In this case, the motor shaft can move by an angle of up to 
360° × p/2.
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6 Technical data
The transport, storage and operating conditions of the safety module can be found in the
technical data of the SI6 drive controller (see Detailed information [} 60]).

The following table contains the variables relevant to safety equipment for the SY6 module
relevant.

SIL CL 3

SIL 3

PL e

Category 4

PFH 5 × 10-9 [1/h]

Length of use 20 years

STO switch-off time < 50 ms

SS1 delay time 10 – 655350 ms (± 1%)

Tab. 1: SY6 – safety-related variables
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7 Commissioning
The following chapters cover starting up your drive controller and the SY6 safety module using
the STOBER DriveControlSuite DS6 software and the TwinSAFE configurator for TwinCAT 2
and TwinCAT 3 from Beckhoff Automation GmbH & Co. KG.

We put forward the following system environment as an example so that it is possible to follow
along with the individual commissioning steps with precision:

§ Beckhoff CX2030 – CPU base module (controller, EtherCAT master)

§ Beckhoff TwinSAFE EL6900 logic terminal (safety controller, FSoE master)

§ Beckhoff EK1100 bus coupler (EtherCAT bus coupler)

§ Beckhoff TwinSAFE 4-channel EL1904 digital input terminal (digital terminal with 4 fail-safe
inputs)

§ Beckhoff TwinCAT 2 or TwinCAT 3 automation software: TwinCAT System Manager
(TwinSAFE configurator), TwinCAT XAE

§ STOBER SI6A drive controller with integrated SY6 safety module

§ STOBER DriveControlSuite DS6 commissioning software in version 6.2 or later

Information

The ability to put the SI6 drive controller and SY6 safety module into operation in conjunction
with the STOBER MC6 motion controller and the STOBER AS6 AutomationControlSuite
development environment is in the pipeline.

Start-up is divided into the following steps:

1. SY6 safety module
Enter a valid FSoE address.

2. DS6 DriveControlSuite
Configure all drive controllers including safety modules, device control, process data for
fieldbus communication and the axes of your drive system in DriveControlSuite. Generate
an ESI file then transmit your project configuration to the drive controller of the system
network.

3. TwinCAT 
Make the generated ESI file available to TwinCAT 2/TwinCAT 3. Next, map your entire
hardware environment and configure it. Then activate your system and check the
TwinSAFE communication of the connected device.
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7.1 SY6: Assigning the FSoE address
In order to be able to identify the SY6 safety module in the FSoE network, you must assign it a
unique address in the FSoE network. The address is based on values from the DIP switches
that are switched to ON (for detailed information, see SY6: Assigning the FSoE address
[} 55]).

Information

Note that the drive controller must be switched off before you enter the FSoE address using the
DIP switches. The drive controller has to be restarted to apply the address.

7.2 DS6: Configuring the drive controller
Project and configure all drive controllers for your drive system using DriveControlSuite.

Information

Always perform the steps included in the following chapters in the specified order!

7.2.1 Initiating the project
In order to be able to configure all drive controllers and axes of your drive system using
DriveControlSuite, you must record them as part of a project already defined in the software.
Afterwards specify your modules in the same way as the project itself.

7.2.1.1 Projecting the drive controller and axis
Create a new project and project the first drive controller along with the accompanying axis.

Creating a new project

1. Start DriveControlSuite.

2. Click on Create new standard project.

ð The projecting window opens and the Drive controller button is active.

Projecting the drive controller

1. Properties tab:
Establish the connection between your diagram and the drive controller to be projected in
DriveControlSuite.
Reference: Specify the reference indicators (equipment indicators) of the drive controller.
Designation: Give the drive controller a unique label.
Version: Create a new version of your projecting.
Description: Specify, if necessary, additional supporting information, such as the change
history of the projecting.

2. Drive controller tab:
Select the series SI6 and the device type of the drive controller.
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3. Option modules tab:
Safety module: Select the SY6 module.

4. Device control tab:
Device control: Select the device controller that defines the underlying activation signals for
the drive controller.
Rx process data, Tx process data: Select EtherCAT Rx and EtherCAT Tx for transmitting
the EtherCAT process data.

Projecting the axis

1. Click on Axis 1.

2. Projecting tab: 
Establish the connection between your circuit diagram and the axis to be projected in
DriveControlSuite.
Reference: Specify the reference indicator (equipment indicator) of the axis.
Designation: Give the axis a unique label.
Version: Create a new version of your projecting.
Description: Specify, if necessary, additional supporting information, such as the change
history of the projecting.

3. Application tab: 
Select the desired controller based application. 
If you are working with hardware and software from Beckhoff, we recommend the
controller-based application CiA 402 Controller Based (incremental version).

4. Motor tab:
Select the type of motor operated using this axis. If you are working with motors from
thirdpart suppliers, enter the accompanying motor data at a later time.

5. Repeat steps 2 – 4 for the second axis (only for double-axis controllers).

6. Confirm with OK.

7.2.2 Parameterizing general EtherCAT settings
ü You have projected the SY6 safety module and the device control with the EtherCAT Rx

and EtherCAT Tx process data as part of drive controller and axis projecting.

1. Highlight the relevant drive controller in the project tree and click on the first projected axis
in the project menu > Wizard area.

2. Select the EtherCAT wizard.

3. A213 Fieldbus scaling:
Define how the PDO elements are transferred (scaled). 
Permitted values: 
1 = Native (values are passed through unchanged) 
0 = Integer without point (values are converted)

4. A258 EtherCAT PDO-Timeout:
In order to be able to detect a communication failure, monitor the arrival of cyclical process
data by defining a PDO timeout. 
Permitted value range: 0 – 65535 ms. 
Please note: 



STOBER 7 | Commissioning
06

/2
01

7 
| I

D
 4

42
74

4.
01

21

0 and 65535 = Monitoring is inactive
1 to 65531 = Monitoring is active
65532 = Monitoring is active but the failure of data package is then ignored
65533 = Monitoring is active but the failure of 3 data packages is then ignored
65534 = Monitoring preset by the SM watchdog function of the EtherCAT master
(monitoring through parameter A259 EtherCAT SM-Watchdog).

7.2.3 Configuring PDO transmission
PDO channels are able to transmit control and status information quickly as well as actual and
target values from an EtherCAT master to EtherCAT slaves and vice versa.

The direction of data flow is important in this data transfer. DS6 differentiates between received
PDO (= RxPDO) and transmitted PDO (= TxPDO) for the EtherCAT slave.

PDO communication allows for a maximum of 4 independent PDO channels to be operated
simultaneously per transmission and sending direction, where channel 4 is a safety channel.
Each of these PDO channels includes a PDO with a defined sequence of up to 24 parameters
to be transmitted (the number of parameters depends on the drive controller type).

In order to guarantee error-free communication between the controller and drive controller,
STOBER offers pre-assignment of the channels which can be changed at any time.

7.2.3.1 Adapting RxPDO

ü You have configured the global EtherCAT settings.

1. Highlight the relevant drive controller in the project tree and click on the first projected axis
in the project menu > Wizard area.

2. Select the EtherCAT assistant > Received process data RxPDO.

3. Check the default settings and/or configure the process data according to your
requirements.
A225[0] – A225[23], A226[0] – A226[23]:
Parameters whose values are received by the drive controller from the controller. The
respective position provides information about the associated receiving sequence.

7.2.3.2 Adapting TxPDO

ü You have configured the global EtherCAT settings.

1. Highlight the relevant drive controller in the project tree and click on the first projected axis
in the project menu > Wizard area.

2. Select the EtherCAT assistant > Transmitted process data TxPDO.

3. Check the default settings and/or configure the process data according to your
requirements.
A233[0] – A233[23], A234[0] – A234[23]: 
Parameters whose values are received by the drive controller from the controller. The
respective position provides information about the associated receiving sequence.
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7.2.4 Transmitting and saving a project configuration
In order to be able to transmit a project configuration to one or more drive controllers, you must
connect your PC to the network.

Transmitting a project configuration

ü In order to be able to transmit a project configuration to one or more drive controllers, you
must connect your PC to the network. The relevant drive controllers are switched on.

1. Highlight the module under which you recorded your drive controller in the project tree and
click on Connection and assignment in the project menu.

ð The Setting up a connection window opens.

2. Direct connection tab > IP address column: 
Highlight the IP address of the relevant drive controller or activate all listed IP addresses
using the context menu. Confirm your selection with OK.

ð The Assignment window opens. All drive controllers connected to the selected network
interface are displayed.

3. Drive controllers connected via communication: 
Select the first drive controller to which you would like to transmit the project configuration
and click on Ignore > Send to drive controller.

4. Click on Create new and select the drive controller.

5. Repeat steps 3 and 4 for all other drive controllers to which you wish to transmit your
project configuration.

6. Click on Establish online connections.

ð The project configuration is transmitted to the drive controllers.

Saving a project configuration

1. Highlight the drive controllers which have been sent the project configuration in the project
tree and click on the first projected axis in the project menu > Wizard area.

2. Select the Save values wizard > Action management area and click on Save values.

3. As the configuration is only effective after a restart of the drive controller, select the Restart
wizard > Action management area and click on Restart.
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7.2.5 Creating and saving ESI files
The functions and properties of the STOBER drive controllers are described in the form of
various objects and collected in an ESI file  called STOBER User specific.xml. 
In order to map and configure one or more drive controllers in the network, generate an ESI
specific to the drive controller and make it available to TwinCAT System Manager in the
directory specified below.

Information

Be aware that TwinCAT can only read in one ESI file per EtherCAT system device. 
A new ESI file must be generated after each change to the drive controller configuration and
made available to TwinCAT.

ü You have configured the PDO transmission.

1. Highlight the relevant drive controller in the project tree and click on the first projected axis
in the project menu > Wizard area.

2. Select the EtherCAT wizard.

3. Click on Create ESI file (EtherCAT Slave Information).

ð The Write ESI file dialog box opens.

4. Save the STOBER User specific.xml file in the directory 
C:\TwinCAT\IO\EtherCAT (default installation).

ð TwinCAT reads in the file when the program is restarted.



7 | Commissioning STOBER

24

06
/2

01
7 

| I
D

 4
42

74
4.

01

7.3 TwinCAT 2: Putting the EtherCAT system into
operation

TwinCAT 2 offers the option of mapping your hardware environment using TwinCAT System
Manager. 
Parameterize all necessary bus parameters in the software automatically via hardware scan.
Next, configure a customized safety program that manages the STO and SS1 safety request
signals. 
Predefined function blocks that connect you to the desired inputs and outputs are available for
this purpose. The configuration of a safety program is described below using the example of the
ESTOP (Emergency Stop) function block. 
Lastly, you will transmit the finished safety program to the FSoE master.

Be aware that it must be possible to obtain unique identification of all FSoE system devices in
the EtherCAT network by means of a customized FSoE address (adjustment via DIP switches).
Assign the respective FSoE addresses before installing and networking the separate devices
and terminals.

Information

Always perform the steps included in the following chapters in the specified order!
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7.3.1 Activating the EtherCAT master and Config mode
ü You have already projected all drive controllers of your system using DriveControlSuite and

transmitted the project configuration to the individual drive controllers. The EtherCAT
master is connected to the network, all safety components have an FSoE address and are
energized, and the infrastructure is ready for operation. You have saved the generated ESI
file in the specified directory. The ESI files for Beckhoff devices are already stored in the
TwinCAT system.

1. Start TwinCAT System Manager.

ð The stored ESI file is read in upon program start and the main window of TwinCAT
System Manager opens. General tab is active.

2. If the run-time package (EtherCAT master) and TwinCAT System Manager have been
installed on the same computer, they are connected to each other automatically. Continue
to step 10.

3. If the run-time package (EtherCAT master) and TwinCAT System Manager have been
installed on different computers, you must connect the computers to each other. Click on
Choose target system.

ð The Choose Target System dialog box opens.

4. Click on Search (Ethernet).

ð The Add Route dialog box opens.

5. Click on Broadcast Search.

ð All available controllers are listed.

6. Highlight the desired controller, activate the IP Address option and confirm with Add Route.

ð The Logon Information dialog box opens.

7. Enter the following information for a new device (TwinCAT standard access) and confirm
with OK:
User name: Administrator
Password: 1

8. Close the Add Route dialog box.

9. Choose Target System dialog box: 
Highlight the previously selected EtherCAT master and confirm with OK.

ð The EtherCAT master is saved as the target system.

10. In order to be able to configure the EtherCAT system online, you must activate the Config
mode of TwinCAT System Manager. 
Select the menu Actions > Set/Reset TwinCAT to Config mode.

ð The Restart TwinCAT System in Config Mode dialog box opens.

11. Confirm with OK.

ð The EtherCAT master is saved as the target system and TwinCAT System Manager is in
Config mode.
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7.3.2 Scanning the hardware environment
If all system components are connected to the EtherCAT network and the network is energized,
it is possible to scan for connected devices automatically. In this scenario, TwinCAT System
Manager searches for connected devices and terminals and integrates them into the existing
project in accordance with their configuration entries in the accompanying ESI files.

If the actual EtherCAT infrastructure is not available, i.e. you are configuring in offline mode, you
must map and project all connected devices manually in TwinCAT System Manager. You can
get more detailed information on this in the online help tool for TwinCAT System Manager.

ü You have activated Config mode.

1. In the tree view, select I/O Configuration > I/O Devices > Context menu Scan Devices.

ð TwinCAT System Manager scans the EtherCAT system for the EtherCAT master. 
The ... new I/O Devices found dialog box opens.

2. Activate the EtherCAT master in question and confirm with OK.

ð The EtherCAT master is arranged in the tree view under I/O devices as device
(EtherCAT). 
The Scan for boxes? dialog box opens.

3. Confirm with Yes.

ð TwinCAT System Manager scans the EtherCAT system for EtherCAT slaves.
The Device(s) added. Append linked axis to NC configuration? dialog box opens.

4. If you would like to activate the NC function, confirm with Yes.

ð The bus coupler EtherCAT slaves (terminal EK1100) along with the FSoE master
(terminal EL6900), the secure inputs (terminal EL1904) and the drive controller (terminal
SI6) are created in the tree view. 
The Activate Free Run dialog box opens.

5. In order to shift the system components during configuration into free run mode and thereby
enable verification of the signal exchange, confirm with Yes.

ð EtherCAT master and slaves are created in the TwinCAT System Manager.

7.3.3 Checking FSoE addresses
The respective FSoE addresses are automatically read into the TwinCAT System Manger
during a hardware scan. Check the TwinSAFE and FSoE addresses of the FSoE master,
secure input terminals and SY6 safety module. Be aware that addresses 0 and 255 are invalid
for SY6.

1. FSoE master:
Navigate to terminal EL6900 in the tree view and switch to the TwinSAFE Logic tab in the
main window.

2. Project area: 
Check the TwinSAFE addresses and correct them if necessary.

3. Input terminal:
Navigate to terminal EL1904 in the tree view and switch to the Safe Parameter tab in the
main window.

4. FSoE Address: 
Check the FSoE address and correct it if necessary.
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5. SY6 safety module:
Navigate to drive controller SI6-FSoE in the tree view and switch to the Safe Parameter tab
in the main window.

6. FSoE Address: 
Check the FSoE address and correct it if necessary.

7.3.4 Configuring parameters for SS1 delay time
Parameterize the SS1 delay time after which the STO function is triggered automatically.

1. SY6 safety module:
Navigate to drive controller SI6 in the tree view and switch to the Safe Parameter tab in the
main window.

2. Parameter T_SS1: 
Double click on the entry.

ð The Set Value dialog window opens.

3. Dec: 
Parameterize the desired SS1 delay time and confirm with OK.

Information

Be aware that the configured value for the SS1 delay time is multiplied by a factor of 10 within
the system (example: T_SS1 = 100, equals 1000 ms). T_SS1 is displayed in parameter
S593SS1 time until STO of DriveControlSuite.

7.3.5 Configuring the TwinSAFE system
The TwinSAFE system consists of a programmable unit, i.e. the FSoE master and secure inputs
and outputs. The FSoE master includes function blocks (TwinSAFE function blocks) that
represent the safety-related logic. The function blocks contain parameters that must be adapted
according to the application.

The first step is to create a TwinSAFE group and then configure the Emergency Stop function
block, for example.

7.3.5.1 Creating a TwinSAFE group
1. In the tree view, navigate to terminal EL6900 > Context menu Append TwinSAFE group.

ð The TwinSAFE group is created in the tree view and the General tab is active.

2. Name this group if necessary and specify this.

3. Switch to the Input/Outputs tab in the main window.

4. Inputs area: 
In order to store signals for activating the safety program, click on RUN/STOP.

ð The Linking of RUN/STOP dialog box opens.

5. Configure a source for the start signal.

6. In order to store the confirmation signal for a possible communication error in the
TwinSAFE group, click on ERR Ack.
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ð The Linking of ERR Ack dialog box opens.

7. Configure a source for the confirmation signal.

ð The TwinSAFE group is created and configured.

7.3.5.2 Configuring the function block
Configure an emergency stop button using the Emergency Stop (ESTOP) function block, which
is connected to the secure input terminal EL1904 by two NC contacts.

7.3.5.2.1 Creating a function block and assigning signal sources

ü You have created and configured a TwinSAFE group.

1. In the tree view, navigate to the TwinSAFE group in question > TwinSAFE Function Block
List  > Context menu Append Function Block.

ð The Insert Function Block dialog block opens.

2. Select Emergency Stop and confirm with OK.

3. Switch to the Emergency Stop tab in the main window.

4. In order to enable operation after an emergency stop using a corresponding signal, click on
Restart.

ð The Linking of Restart dialog box opens.

5. Select the source for the restart signal.

6. In order to project the input circuit, click on the accompanying tool symbol of the input pair
EStopIn1 and EStopIn2.

ð The Function Block Input Settings dialog box opens.

7. Project the input circuit according to your wiring and confirm with OK.

8. Click on EStopIn1.

ð The Linking of EStopIn1 dialog box opens.

9. Insert new link area: 
Activate the TwinSAFE Input option and click on New.

ð The Attach TwinSAFE Variable dialog box opens.

10. Highlight the first input channel for terminal EL1904 and confirm with OK.

11. Click on EStopIn2 and as with EStopIn1, assign the second input channel for terminal
EL1904.

12. Click on EStopOut.

ð The Linking of EStopOut dialog box opens.

13. Insert New Link area: 
Activate the TwinSAFE Output option and click on New.

ð The Attach TwinSAFE Variable dialog box opens.

14. Highlight the SS1 output of the SI6 drive controller and confirm with OK.

15. Click on EStopDelOut and as with EStopOut, assign the STO output of the SI6 drive
controller.
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16. Enter the SS1 delay time that was parameterized ahead of time in SY6 safety module >
T_SS1.

ð The configured function block is available for download to the FSoE master.

7.3.5.2.2 Transmitting the function block

Transmit the configured function block to the FSoE master.

ü Config mode is activated.

1. In the tree view, navigate to terminal EL6900 and switch to the TwinSAFE Verifier tab in the
main window.

2. Click on Download.

ð The Login dialog box opens. 
The download on the FSoE master is password-protected.

3. Enter the following information for a new device (TwinCAT standard access) and confirm
with OK:
User Name: Administrator
Serial No.: Serial number of the FSoE master 
Password: TwinSAFE

ð The Project dialog box opens.

4. Begin the download by clicking on Start.

ð The Login dialog box opens.

5. Enter the TwinSAFE password again.

ð The function block is transmitted to the FSoE master.

6. Restart the TwinCAT system: 
Select the menu Actions > Set/Reset TwinCAT to Config Mode.

ð The Restart TwinCAT System to Config Mode dialog box opens.

7. Confirm with OK.

ð The Load I/O Devices dialog box opens.

8. Confirm with Yes.

ð The Activate Free Run dialog box opens.

9. Confirm with Yes.

ð The function block is transmitted to the FSoE master and the safety program can be
handled in Config mode (free run).
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7.3.6 Checking the hardware status
FSoE communication with connected devices in an EtherCAT system requires that the
EtherCAT master and slaves be in the OP (Status Operational) device state. Check the device
state of the master and of the TwinSAFE group.

1. In the tree view, navigate to the EtherCAT master and switch to the Online tab in the main
window.

ð All devices of the EtherCAT system are listed.

2. State column: 
All devices must be in the OP state. 
If not, highlight the device in question and click on Op in the Actual State area.

3. In the tree view, navigate to the TwinSAFE group and switch to the Input/Outputs tab in the
main window.

4. Online:
Activate this option.

ð The status of the group must be set to RUN.

ð The EtherCAT system that you have configured is ready for communication.

Information

If the TwinSAFE group is not in the RUN state, check the FSoE addresses of all EtherCAT-
connected devices.
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7.4 TwinCAT 3: Putting the EtherCAT system into
operation

TwinCAT 3 offers the option of mapping your hardware environment using TwinCAT XAE. 
Parameterize all necessary bus parameters in the software automatically via hardware scan.
Next, configure a customized safety program that manages the STO and SS1 safety request
signals. 
Predefined function blocks that connect you to the desired inputs and outputs are available for
this purpose. The configuration of a safety program is described below using the example of a
safeEstop (Emergency Stop) function block.
You will transmit the finished safety program to the FSoE master as the last step.

Be aware that it must be possible to obtain unique identification of all FSoE system devices in
the EtherCAT network by means of a customized FSoE address (adjustment via DIP switches).
Enter the FSoE addresses before installing and networking the individual devices and terminals.

Information

Always perform the steps included in the following chapters in the specified order!
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7.4.1 Activating the EtherCAT master and Config mode
ü You have already projected all drive controllers of your system using DriveControlSuite and

transmitted the project configuration to the individual drive controllers. The EtherCAT
master is connected to the network, all safety components have an FSoE address and are
energized, and the infrastructure is ready for operation. You have saved the generated ESI
file in the specified directory. The ESI files for Beckhoff devices are already stored in the
TwinCAT system.

1. Start TwinCAT XAE.

ð The stored ESI file is read in upon program start and the main window of TwinCAT
System Manager opens. Start page tab is active.

2. Select File > New > Project.

ð The New Project dialog box opens.

3. Select Installed > Templates > TwinCAT Projects > TwinCAT XAE Project (XML format).

4. Name, Location, Solution name: 
Label the project and enter a save location and an internal project name.

5. If the run-time package (EtherCAT master) and TwinCAT XAE have been installed on the
same computer, they are connected to each other automatically. Continue to step 13.

6. If the run-time package (EtherCAT master) and TwinCAT System Manager have been
installed on different computers, you must connect them to each other. 
Click on the <Local> list field in the TwinCAT XAE toolbar and select Choose Target
System.

ð The Choose Target System dialog box opens.
7. Click on Search (Ethernet).

ð The Add Route dialog box opens.
8. Click on Broadcast Search.

ð All available controllers are listed.

9. Highlight the desired controller, activate the IP Address option and confirm with Add Route.

ð The Logon Information dialog box opens.

10. Enter the following information for a new device (TwinCAT standard access) and confirm
with OK:
User name: Administrator
Password: 1

11. Close the Add Route dialog box.

12. Choose Target System dialog box: 
Highlight the previously selected EtherCAT master and confirm with OK.

ð The EtherCAT master is saved as the target system.

13. In order to be able to configure the EtherCAT system online, you must activate Config
mode for the TwinCAT XAE software. 
Select the menu TWINCAT > Restart TwinCAT (Config mode).
ð The Restart TwinCAT System in Config Mode dialog box opens.

14. Confirm with OK.

ð The EtherCAT master is saved as the target system, TwinCAT XAE is in Config mode.
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7.4.2 Scanning the hardware environment
If all system components are connected to the EtherCAT network and the network is energized,
it is possible to scan for connected devices automatically. In this scenario, TwinCAT XAE
searches for connected devices and terminals and integrates them into the existing project in
accordance with their configuration entries in the accompanying ESI files.

If the actual EtherCAT infrastructure is not available, i.e. you are configuring in offline mode, you
must map and project all connected devices manually in TwinCAT XAE. You can get more
detailed information on this in the online help tool of the TwinCAT XAE software.

ü You have activated Config mode.

1. In the solution explorer, select I/O > Devices > Context menu Scan.

ð TwinCAT XAE scans the EtherCAT system for the EtherCAT master. 
The ... new I/O devices found dialog box opens.

2. Activate the EtherCAT master in question and confirm with OK.

ð The EtherCAT master is created in the solution explorer under I/O > Devices as a
device (EtherCAT). 
The Scan for boxes? dialog box opens.

3. Confirm with Yes.

ð TwinCAT XAE scans the EtherCAT system for EtherCAT slaves.
The EtherCAT drives added dialog box opens.

4. Append linked axis to:
If a NC or CNC function is required, activate the desired option and confirm with OK.

ð The bus coupler EtherCAT slaves (EK1100 terminal) along with the FSoE master
(EL6900 terminal), secure inputs (EL1904 terminals) and the drive controller (SI6
terminal) are created in the solution explorer. 
The Activate Free Run dialog box opens.

5. In order to shift the system components during configuration into free run mode and thereby
enable verification of the signal exchange, confirm with Yes.

ð EtherCAT master and slaves are created in TwinCAT XAE.
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7.4.3 Configuring the TwinCAT SAFETY project
A TwinCAT SAFETY project consists of a TwinSAFE group with alias devices, i.e. the hardware
components of your system and the actual SAFETY element along with accompanying function
blocks that represent safety-related logic. The function blocks contain parameters that must be
adapted according to the application.

The first step is to create a SAFETY project along with alias devices and then configure the
function block safeEstop, for example.

7.4.3.1 Creating the TwinCAT SAFETY project
1. In the solution explorer, navigate to SAFETY > Context menu Add New Item.

ð The Add New Item dialog box opens.

2. Highlight the entry TwinCAT Default Safety Project.

3. Name: 
Label the SAFETY project and confirm with Add.

ð The TwinCAT Safety Project Wizard dialog box opens.

4. Internal Project Name: 
If necessary, enter an internal project name and confirm with OK.

ð The SAFETY project with the name you provided, a target system and a TwinSAFE
group are created in the solution explorer. The TwinSAFE group already includes a
folder for the alias devices to be created; the alias device ErrorAcknowledgement.sds is
available as a reset input by default.

5. In order to define the FSoE master as the target system, select the newly created SAFETY
project in the solution explorer and double click on Target System.

6. Main window > Physical Device: 
Click on the appropriate icon.

ð The Choose physical terminal for mapping dialog box opens.

7. Terminal: 
Highlight the EL6900 FSoE master and confirm with OK.

8. Main window > Hardware Address: 
The FSoE address of the FSoE master has been read into TwinCAT XAE automatically.

9. In order to save the project, select the menu FILE > Safe Selected Items.

ð The SAFETY project is created and the FSoE master is configured as the associated target
system.
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7.4.3.2 Creating alias devices
The hardware required for the SAFETY project is incorporated into the TwinSAFE group as the
respective alias device.

1. In the solution explorer, navigate to your SAFETY project > TwinSafeGroup1 > Alias
Devices > Context menu Add > New Item.

ð The Add New Item dialog box opens.

2. Create an alias device as an input for the start of the TwinSAFE group. 
Select  Installed > Standard  > 1 Digital Input (Standard).

3. Name: 
Label the alias device with RUN and confirm with Add.

4. In the solution explorer, reselect the folder Alias devices > Context menu Add > New item.

5. Create an alias device for the secure inputs (terminal EL1904). 
Select Safety  > EtherCAT > Beckhoff Automation GmbH > 4 digital inputs.

6. Name: 
If necessary, label the device and confirm with Add.

7. In the solution explorer, reselect the folder Alias devices > Context menu Add > New item.

8. Create an alias device for the drive controller with the integrated SY6 safety module. 
Select Safety  > EtherCAT > STOEBER ANTRIEBSTECHNIK GmbH & Co. KG >
0xB1EC5956 - Safety (FSoE).

9. Name: 
If necessary, label the device and confirm with Add.

ð The named hardware components are created as alias devices for the TwinSAFE group in
the solution explorer.

7.4.3.3 Assigning alias devices and entering FSoE addresses
Assign the created alias devices to the individual hardware components of your system and
enter the accompanying FSoE addresses.

1. In the solution explorer, navigate to your SAFETY project > TwinSafeGroup1 > Alias
Devices and double click on ErrorAcknowledgement.sds.

2. Main window > Full name: 
Click on the appropriate icon.

ð The Attach Variable Standard in Var 1 (output) dialog box opens.

3. Show Variables:
In order to display all devices, activate the option Used and unused.

4. Show Variables: 
In order to display the standard inputs, uncheck the checkbox Exclude other devices.

5. Select the desired standard input for the reset of the TwinSAFE group and confirm with OK.

6. In the solution explorer, select the folder Alias Devices and double click on RUN.sds.

7. Main window > Full name: 
Click on the appropriate icon.

ð The Attach Variable Standard in Var 1 (output) dialog box opens.
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8. Select the desired standard input for starting the TwinSAFE group and confirm with OK.

ð The hardware standard inputs for resetting and starting the TwinSAFE group are linked
with the accompanying alias devices.

9. In the solution explorer, select the folder Alias Devices and double click on 4 digital
inputs_1.sds.

10. Main window > Linking tab > Physical Device: 
Click on the accompanying icon.

ð The Choose physical channel dialog box opens.

11. Select the first module of the EL1904 terminal and confirm with OK.

ð Terminal EL1904 is linked with the corresponding alias device.

12. Linking tab > FSoE address: 
The FSoE address of the EL1904 terminal has been read into the TwinCAT XAE Dip
Switch field during the hardware scan automatically. In order to apply the address, click on
the accompanying icon.

ð The address is taken from the Dip switch field and input into the FSoE address field.

13. In the solution explorer, select the folder Alias Devices and double click on 0xB1EC5956 –
Safety(FSoE).sds.

14. Main window > Linking tab > Physical Device: 
Click on the accompanying icon.

ð The Choose physical channel dialog box opens.

15. Select the first module of the drive controller with the integrated SY6 safety module and
confirm with OK.

ð The drive controller is linked with the corresponding alias device.

16. Linking tab > FSoE address: 
The FSoE address of the safety module has been read into the TwinCAT XAE Dip switch
field during the hardware scan automatically. In order to apply the address, click on the
accompanying icon.

ð The address is taken from the Dip switch field and input into the FSoE address field.

17. In order to configure the SS1 delay time after which the STO function is triggered
automatically, select in the main window > Safety Parameters tab > T_SS1 parameter.

18. T_SS1:
Double click on the entry.

ð The Set Value dialog window opens.

19. Dec.:
Parameterize the parameters for the desired SS1 delay time and confirm with OK.

ð Be aware that the configured value here is multiplied by a factor of 10 within the system
(example: T_SS1 = 100, equals 1000 ms). 
T_SS1 is displayed in parameter S593 SS1 time until STO of DriveControlSuite.

ð The hardware components are linked with the corresponding alias devices and the FSoE
addresses entered.
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7.4.3.4 Configuring the function block
Using the safeEstop function block, configure an emergency stop button that is connected to the
secure input terminal EL1904 via two NC contacts.

7.4.3.4.1 Creating a function block and assigning signal sources

1
3

2

4 5

Fig. 5: TwinCAT 3 – Configuring safeEstop function block and assigning signal sources

1. In the solution explorer, navigate to your SAFETY project > TwinSafeGroup1 and double
click on TwinSafeGroup1.sal (1).

2. VIEW menu (2): 
Open the Toolbox view.

3. Toolbox > Function blocks (boolean) (3): 
Drag and drop the safeEstop function block into the main window > TwinSafeGroup1.sal
tab.

4. Click to the left of the icon for Restart.

5. Label the variable with RestartInput.

6. Click to the left of the icons for both EStopIn1 and EStopIn2.

7. Label the variables with Channel1 and Channel2.

8. Click to the right of the icons for both EStopOut and EStopDelOut.

9. Label the variables with Stop and StopVerz.
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10. Delay time (ms): 
Enter the SS1 delay time configured in T_SS1 . 
Be aware that the value in this entry field is NOT multiplied by a factor of 10 within the
system.

ð All necessary variables for configuring the safeEstop function block have been created.

11. In the message view, switch to the Variable Mapping tab > Variables subtab (4).

ð The previously defined variables for the function block are listed in the Assigned
Variable column.

12. RestartInput variable > Alias Port column: 
Click on the accompanying button.

ð The Map to dialog box opens.

13. Usage: 
Activate the Used and unused option.

14. Assign the ErrorAcknowledgement alias device to the variable and confirm with OK.

15. Variables subtab > Variables Channel1 and Channel2 > Alias port column: 
Click on the accompanying buttons.

ð The Map to dialog box opens.

16. Assign the alias device 4 digital inputs > Channel1 > InputChannel1 to the variable
Channel1 and 4 digital inputs > Channel2 > InputChannel2 to the variable Channel2 and
confirm with OK.

17. Variables subtab > Variables Stop and StopVerz > Alias Port column: 
Click on the accompanying buttons.

ð The Map to dialog box opens.

18. Assign the alias device 0xB1EC5956 - Safety (FSoE)  > Channel > SS1 to the variable
Stop and the alias device 0xB1EC5956 - Safety (FSoE)  > Channel > STO to variable
StopVerz, confirm with OK.

ð All configured variables for the safeEstop function block have been linked to the
associated alias devices.

19. Switch to the Group Ports subtab (5).

20. Variables ErrAck and Run/Stop > Alias Port column: 
Click on the accompanying buttons.

ð The Map to dialog box opens.

21. Usage: 
Activate the Used and unused option.

22. Assign the alias devices ErrorAcknowledgement and RUN of the TwinSAFE group to the
variables, respectively, and confirm with OK

ð The configured function block is available for download to the FSoE master.
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7.4.3.4.2 Transmitting the function block

Validate the configured function block and transmit this to the FSoE master.

1. In the solution explorer, navigate to your SAFETY project > TwinSafeGroup1 and double
click on TwinSafeGroup1.sal.

2. Select the menu TWINSAFE > Verify Complete Safety Project.

3. If validation was successful, the status VERIFICATION PROCESS SUCCEEDED is displayed
in the left area of the footer of the TwinCAT XAE interface.

4. Select the menu TWINSAFE > Download Safety Project.

ð The Check if the addresses configured on hardware terminals [...] dialog box opens.

5. Confirm the prompt with Yes.

ð The Download Project Data > Steps: Login dialog box opens. 
The download to the FSoE master is password-protected.

6. Login area:
Enter the following information for a new device (TwinCAT standard access) and confirm
with Next: 
Username: Administrator
Serial Number: Serial number of the FSoE master
Password: TwinSAFE

ð The Download Project Data > Steps: Download dialog box opens.

7. Begin the download by clicking on Next.

ð The Download Project Data > Steps: Final Verification dialog box opens.

8. Final Verification area > I have manually verified the data shown [...] confirmation prompt:
Check the configured data, confirm the confirmation prompt by checking the accompanying
checkbox and click on Next.

ð The Download Project Data > Steps: Activation dialog box opens.

9. Activation area > Password: 
Enter the TwinSAFE password again and confirm with Finish.

ð The function block is transmitted to the FSoE master.

10. Restart the TwinCAT system: 
Select the menu Actions > Set/Reset TwinCAT to Config Mode.

ð The Restart TwinCAT System in Config Mode dialog box opens.

11. Confirm with OK.
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7.4.4 Checking the function of the TwinSAFE group
Check that the TwinSAFE group functions correctly.

1. In the solution explorer, navigate to your SAFETY project > TwinSafeGroup1 and double
click on TwinSafeGroup1.sal.

2. Select the menu TWINSAFE > Show Online Data.

ð The FSoE master (terminal EL6900) is stopped, the safeEstop function block is
deactivated, the accompanying status is set to red.

3. Start the TwinSAFE group via RUN = true.

4. Unlock the emergency stop button and press the reset button.

ð The function block is not active and the TwinSAFE group works correctly.
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8 Diagnostics
In the event of fault, the various diagnostic options described below are available.

8.1 LED display
STOBER drive controllers have diagnostic LEDs that visually indicate the state of the drive
controller as well as the states of the physical connection and communication.

3

2
1

5

4

Err

Run

FSoE

Fig. 6: Positions of the diagnostic LEDs on the front and top of the drive controller

1 Fieldbus device state

2 FSoE state

3 State of the drive controller

4 Service network connection

5 Fieldbus network connection
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8.1.1 Fieldbus device state
2 LEDs on the front of the device provide information about the fieldbus device state.

2
1 Err

Run

FSoE

Fig. 7: LEDs for the fieldbus device state on the front of the drive controller

1 Red: ERROR

2 Green: RUN

Red LED Behavior Error according to
ETG

Description

Off No Error No error

Flashing Invalid
Configuration

Configuration not valid

Single flash Unsolicited State
Change

Drive controller independently
changed its fieldbus device state

Double flash Application
Watchdog Timeout

Drive controller has not received
any new PDO data within the set
timeout period

Tab. 2: Meaning of the red LED (ERROR indicator in accordance with ETG.1300)

Green LED Behavior State in
accordance with
ETG

Description

Off Init state No communication between
master and drive

Flashing Pre-operational Process data traffic not possible

Single flash Safe-operational Actual values of the drive are
transferred to the master;
reference values can be sent to
the drive only via SDO

On Operational Complete process data traffic is
active; reference values can now
be sent to the drive and actual
values can be received from the
drive

Tab. 3: Meaning of the green LED (RUN indicator in accordance with ETG.1300)
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8.1.2 FSoE state
If the drive controller includes the SY6 safety module, the STO and SS1 safety functions are
activated over EtherCAT FSoE. In this case, an LED on the front of the device provides
information about the FSoE state. This information can also be read out in parameter S20 FSoE
status.

1

Err

Run

FSoE

Fig. 8: FSoE LED on the front of the drive controller

1 Green: FSoE

Green LED Behavior Possible in FSoE
state

Description

Off Pre-Reset Initialization

Flashing Reset, session,
connection,
parameters

Ready for parameterization

On Process data Normal operation

Single flash Failsafe data Failsafe command from FSoE
master received

Rapid flashing All Undefined connection error

Rapid blinking
with 1x flash

Parameters Error in the safety-related
communication parameters

Rapid blinking
with 2x flash

Parameters Error in the safety-related
application parameters

Rapid blinking
with 3x flash

Connection Incorrect FSoE address

Rapid blinking
with 4x flash

All Prohibited command received via
the FSoE communication
interface

Rapid blinking
with 5x flash

All Watchdog error

Rapid blinking
with 6x flash

All CRC error

Tab. 4: Meaning of the green LED (FSoE status in accordance with IEC 61784-3)
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8.1.3 Drive controller state
3 LEDs on the front of the device provide information about the state of the drive controller.

2
3

1

Fig. 9: LEDs for the state of the drive controller on the top of the device

1 Green: RUN

2 Red: ERROR in axis controller A

3 Red: ERROR in axis controller B (only for double-axis controllers)

Green LED Behavior Description

Off No supply voltage or axis controller A or B faulty

Single flash STO active

Flashing At least 1 axis controller ready to switch on; no axis
controller faulty

On At least 1 axis controller enabled; no axis controller
faulty

Rapid flashing Data is written to internal memory and the SD card

Tab. 5: Meaning of the green LED (RUN)

Red LED Behavior Description

Off No error

Flashing Warning

On Fault

Rapid flashing No configuration active

Tab. 6: Meaning of the red LEDs (ERROR)

Pattern when starting the drive controller

LEDs:
Green/Red/Red

Behavior Description

On Short phase while the firmware starts up

On

On

Tab. 7: States of the LEDS when starting the drive controller
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Pattern for the firmware update

The states of the green and red LEDs also apply as described during a live firmware update. In
the following exceptional cases, the three LEDs flash in different combinations and frequencies:

LEDs:
Green/Red/Red

Behavior Description

Off Deleting the first firmware memory

Rapid flashing

Off

Rapid flashing Copying the second firmware memory into the first

Off

Off

Chaser light Error during firmware update, service required

Tab. 8: States of the LEDs for firmware updates

Pattern for CPU error

LEDs:
Green/Red/Red

Behavior Description

Alternate
flashing

Off

CPU error

Tab. 9: States of the LEDs for firmware updates
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8.1.4 Service network connection
The LEDs at X9 on the front of the device display the state of the service network connection.

2

1

Fig. 10: LEDs for the state of the service network connection on the front of the drive controller

1 Green: LINK

2 Yellow: ACTIVITY

Green LED Behavior Description

Off Physical connection not available

On Physical connection to the network is available and link
is set up

Tab. 10: Meaning of the green LED (LINK)

Yellow LED Behavior Description

Off Physical connection not available

Flashing Individual data packages are sent or received

On Continuous data communication

Tab. 11: Meaning of the yellow LED (ACTIVITY)
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8.1.5 Fieldbus network connection
The LEDs LA ECIN and LA ECOUT at X200 and X201 on the top of the device display the state of
the network connection.

L
A

L
A

2

4

3

1

IN
E
C

X
2
0
0
:

O
U
T

E
C

X
2
0
1
:

Fig. 11: LEDs for the state of the network connection on the top of the drive controller

1 Green: LA ECOUT at X201

2 Yellow: No function

3 Green: LA ECIN at X200

4 Yellow: No function

Green LED Behavior Description

Off Physical connection not available

On Physical connection to other Ethernet devices is
available

Flashing Data exchange with other Ethernet devices is active

Tab. 12: Meaning of the green LEDs (LA)
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8.2 Parameters
The following parameters are significant for safety equipment in combination with the SI6 drive
controller and SY6 safety module.

8.2.1 E54 Information safety module | G6 | 0
Signifying data of the safety module.

[0]: Type

[1]: Hardware version

[2]: Serial number

[3] – [5]: Reserved

[6]: Diagnostic code

§ Bit 0: 
1 = Internal OSSD channel error

§ Bit 1: 
Reserved

§ Bit 2: 
1 = FSoE communication error

§ Bit 3: 
Reserved

§ Bit 4: 
1 = Overheat

§ Bit 5: 
Reserved

§ Bit 6: 
1 = SS1 time engaged

§ Bit 7: 
1 = STO in safe state

8.2.2 E67 STO state | G6 | 1
STO state of the safety module:

[0]: 1 = STO triggered by input signal STOa = 0 or STOb = 0

[1]: 1 = STO triggered by input signal STOa = 0

[2]: 1 = STO triggered by input signal STOb = 0

§ 0: Inactive

§ 1: Active
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8.2.3 S20 FSoE status | SI6 | 0
FSoE connection state

§ 0x0 = Initialization
Possible in the FSoE state of Pre-Reset

§ 0x1 = Ready for parameterization
Possible in the FSoE states of Reset, Session, Connection, and Parameter

§ 0x2 = Normal operation
Possible in the FSoE state of Process Data

§ 0x3 = Failsafe command from FSoE master received
Possible in the FSoE state of Failsafe Data

§ 0x4 = Undefined connection error
Possible in all FSoE states

§ 0x5 = Error in the safety-related communication parameters
Possible in the FSoE state of Parameter

§ 0x6 = Error in the safety-related application parameters 
Possible in the FSoE state of Parameter

§ 0x7 = Incorrect FSoE address 
Possible in the FSoE state of Connection

§ 0x8 = Prohibited command received via FSoE communication interface
Possible in all FSoE states

§ 0x9 = Watchdog error
Possible in all FSoE states

§ 0xA = CRC error
Possible in all FSoE states

8.2.4 S21 FSoE slave address | SI6 | 0
FSoE slave address assigned via DIP switch.

An address change takes effect the next time the device is restarted.

8.2.5 S25 Diagnostic code SY6 | SI6 | 0
Diagnostic code of the SY6 safety module.

§ Bit 0: 
1 = Internal OSSD channel error

§ Bit 1: 
Reserved

§ Bit 2: 
1 = FSoE communication error

§ Bit 3: 
Reserved

§ Bit 4: 
1 = Overheat
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§ Bit 5: 
Reserved

§ Bit 6: 
1 = SS1 time engaged

§ Bit 7: 
1 = STO in safe state

8.2.6 S130 Run time | G6 | 0
Operating time of the safety module.

8.2.7 S544 Safety controlword | SI6 | 0
Safety control byte for FSoE.

Corresponds to the Safety controlword communication object, 1st byte and 2nd byte in
accordance with ETG.6100.1.

[0]: First byte; index 0x6620, subindex 0x1

§ Bit 0: * STO
0 = Activate STO

§ Bit 1: * SS1
0 = Activate STO

§ Bit 2 – 7: Reserved

* Enabling the power unit requires that both bits be set to 1

-[1]: Second byte; reserved; index 0x6620, subindex 0x2

8.2.8 S545 Safety statusword | SI6 | 0
Safety status byte for FSoE.

Corresponds to the Safety statusword communication object, 1st byte and 2nd byte in accordance
with ETG.6100.1.

[0]: First byte; index 0x6621 subindex 0x1

§ Bit 0: STO
1 = STO active

§ Bit 1 – 7: Reserved

[1]: Second byte; reserved; index 0x6621 subindex 0x2

8.2.9 S593 SS1 time until STO | SI6 | 0
SS1 delay time, i.e. the duration (in 10 ms increments) between the activation of a time-based
SS1 by S544Safety controlword, bit 1, and the internal triggering of the STO function.

Corresponds to the communication object index 0x6651, subindex 0x0 SS1 time until STO in
accordance with ETG.6100.1.

A change to the SS1 delay time in the FSoE master takes effect and becomes visible in
parameter S593 the next time the FSoE master is restarted.
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8.3 Events
Possible events, the causes and suitable measures for which are listed below.

8.3.1 Event 50: Safety module
The drive controller is interrupted.

§ The power unit is disabled, the drive controller no longer controls axis motion.

§ The holding brakes are no longer controlled by the drive controller and engage in the event
of an inactive purge override F06.

Causes and actions

Number Cause Check and action

2: Wrong safety
module

The safety module
projected in E53 does not
match that detected in
E54[0]

Check the projecting and drive controller and
correct the projecting or exchange the drive
controller if necessary; fault cannot be
confirmed

3: Internal error Defective safety module Exchange drive controller; fault cannot be
confirmed

Tab. 13: Event 50 – Causes and actions
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9 More information on FSoE, safety
functions and SY6

This chapter summarizes the important terms, relationships and measures regarding FSoE, the
STO and SS1 safety functions and the SY6 safety module.

9.1 FSoE: Fail Safe over EtherCAT
The safety protocol known as Safety over EtherCAT (FSoE = Fail Safe over EtherCAT) exists
in parallel with the real-time Ethernet system EtherCAT for transmitting safety-related
messages between FSoE devices in a network. The protocol is TÜV-certified and internationally
standardized in accordance with the IEC 61784-3 standard. The design of FSoE is based on the
black channel principle.

Secure communication

During each FSoE cycle, a FSoE master sends safety-related data to a FSoE slave and
simultaneously starts a watchdog timer. The FSoE slave acknowledges the received data
before sending it back to the master and also begins run-time monitoring via a watchdog timer.
The master receives and processes the confirmation from the slave and stops the watchdog
timer. If the data has been fully processed, the FSoE master generates a new data package.

Unique FSoE addressing

It must be possible to identify each FSoE slave using a unique FSoE address.

The address is assigned to the device using a DIP switch. A valid address is within the address
range 1 – 65534 (16 bit, 0 address may not be assigned).

9.2 Safety functions
The SY6 safety module supports the Safe Torque Off (STO) and Safe Stop 1 (SS1-t) safety
functions. The safety controller must activate the STO as well as the SS1 output of the drive
controller if the drive axis is to be moved. If only one of the outputs is configured, the drive
controller remains in a safe state (STO active).

The safety functions relate to the device and are not axis-specific. This means that for multi-axis
controllers, only the entire drive controller can be set to a safe state, not individual axes.
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9.2.1 Safe Torque Off – STO

STO

Torque
on Motor

Speed

t

t

t

t

STO State

1

n

1

On

Fig. 12: STO function principle in accordance with ETG.6100.2

STO corresponds to stop category 0 in accordance with EN 60204.

STO is the most fundamental drive-integrated safety function. STO prevents energy from being
able to generate torque in the connected motor and will prevent unintentional start-up. The goal
is to safely eliminate material damage and injuries to persons caused by a rotating,
unintentionally activated motor.

The use of STO is always suitable if the motor comes to a standstill on its own in a sufficiently
short time period due to load torque or friction or in an environment in which motor coasting
does not have safety-related implications.
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9.2.2 Safe Stop 1 – SS1

SS1

Speed

t

t

t

t

STO State

1

On

1

Torque
on Motor

t

1

SS1 State

T_SS1
t0 t1

n

Fig. 13: SS1 function principle in accordance with ETG.6100.2

t0 SS1 activation

t1 STO activation

T_SS1 SS1 delay time

SS1 corresponds to stop category 1 in accordance with IEC 60204-1.

The SS1-t safety function brings about the time-controlled standstill of a motor and
subsequently switches it to a torque-free state, i.e. the STO safety function is activated. STO is
triggered after a time delay, regardless of whether the motor has already reached a standstill.

The SS1 delay time T_SS1 is a safety-related parameter configured in TwinCAT System
Manager and transmitted to the FSoE master. Upon initialization of the FSoE protocol , the
value of this parameter is transferred from the safety controller to the drive controller and
displayed in DriveControlSuite via parameter S593 SS1 time until STO.
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9.3 SY6: Assigning the FSoE address
In order to be able to provide unique identification of the SY6 safety module in the FSoE
network, you must assign a FSoE address from the address range 1 – 255 manually using a
DIP switch. An address of 0 is invalid, i.e. the value is ignored if an address of 0 is assigned and
the SY6 remains in the STO state.

Information

Note that the drive controller must be switched off before you enter the FSoE address using the
DIP switches. The drive controller has to be restarted to apply the address.

FSoE address input using a DIP switch

The DIP switch for entering the address is located on the top of the drive controller. The
address is based on the values from the DIP switches that are switched ON. The following
graphic shows the SY6 safety module along with the DIP switches with the values 2 and 8; the
associated FSoE address is 10.

Fig. 14: SY6 – DIP switch

Switch number 1 2 3 4 5 6 7 8

Value – FSoE address 1 2 4 8 16 32 64 128

Tab. 14: DIP switch and FSoE addresses

Checking the FSoE address in DriveControlSuite

You can verify the FSoE address you have entered for the SY6 safety module using the
parameter S21 FSoE slave address in DriveControlSuite.
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9.4 Safety system time

System time

Sensor Safe
input

FSoE
master

EtherCAT
master

EtherCAT
master

Drive
controller

Communication Communication

Reaction time Reaction time Reaction time Reaction timeReaction timeReaction time

Fig. 15: Reaction times and safety system time

STO system time is understood as the time span from the request for safe switch-off (STO) at a
sensor until the actual safe switch-off at the EtherCAT connection of the drive controller.

The system time depends on the response times of the individual system components and the
communication and transmission times in the EtherCAT group.

The accompanying processes are:

§ Sensor: 
Providing the STO request signal

§ Safety terminal (safe input): 
Detecting the STO request signal

§ EtherCAT master: 
Transmitting the state of the safe input to the FSoE master

§ FSoE master: 
Evaluating the STO request signal

§ EtherCAT master: 
Transmitting the STO request signal to the drive controller

§ Drive controller: 
Activating and switching off STO (STO switch-off time); this process is divided into the
following:

• EtherCAT processing time in the control unit

• Transfer time of the data package to the SY6 safety module

• SY6: Duration for evaluating the data package

• Switch-off time of the power output stage
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9.5 FSoE: Watchdog time
In order to detect possible faults, the communication between FSoE master and slave is
monitored by a FSoE watchdog. Once a FSoE message has been sent, the master as well as
slave start a watchdog. If the master or slave receive no corresponding response message
before the watchdog time runs out, the respective device switches into a safe state. The
watchdog time is taken into account when calculating the worst case response time.

The watchdog time is parameterized individually for each slave using the FSoE master; for
TwinCAT 2 and TwinCAT 3, a universal watchdog time of 100 ms is set by default. If you would
like to change this default time, switch to the TwinSAFE connection list of the TwinSAFE group
in question for TwinCAT 2 or to the properties of the respective alias devices of a TwinSAFE
group for TwinCAT 3.
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10 Appendix

10.1 Supported communication objects

10.1.1 0x6600 – 0x67FF: ETG.6100.3 Safety over EtherCAT Drive
Profile

The following table includes the supported communication objects of the standardized
ETG.6100.3 Safety over EtherCAT Drive Profile and their mapping to the corresponding
STOBER-specific parameters.

Index Subindex PDO Editable Name Comment

0x6600 0x0 — — Time unit Unit: 10 ms

0x6620 Safety controlword

0x6620 0x0 — — Highest subindex
supported

Constant value of 2

0x6620 0x1 — — Safety controlword, 
1st byte

S544[0]

0x6620 0x2 — — Safety controlword, 
2nd byte

S544[1]; 
no function

0x6621 Safety statusword

0x6621 0x0 — — Highest subindex
supported

Constant value of 2

0x6621 0x1 — — Safety statusword, 
1st byte

S545[0]

0x6621 0x2 — — Safety statusword, 
2nd byte

S545[1]; no function

0x6640 0x0 — — STO command supported Constant value of 1

0x6641 0x0 — — STO restart acknowledge Constant value of 0

0x6650 0x0 — — SS1 command supported Constant value of 1
(function is supported)

0x6651 0x0 — — SS1 time to STO S593, unit defined in
0x6600

Tab. 15: Communication objects ETG.6100.3: 0x6600 – 0x67FF
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10.1.2 0xE000 – 0xEFFF: ETG.5001.4 Safety over EtherCAT
The following table includes the supported communication objects of the standardized
ETG.5001.4 Safety over EtherCAT .

Index Subindex PDO Editable Name Comment

0xE901 FSoE connection
communication
parameter

0xE901 0x0 — — Highest subindex
supported

Constant value of 8

0xE901 0x1 — — Version

0xE901 0x2 — — FSoE slave address

0xE901 0x3 — — Connection ID

0xE901 0x4 — X Watchdog time

0xE901 0x5 — — Reserved

0xE901 0x6 — — Connection type

0xE901 0x7 — — ComParameterLength

0xE901 0x8 — — ApplParameterLength

0xF980 0x0 — — FSoE slave address

Tab. 16: ETG.5001.4 communication objects: 0xE000 – 0xEFFF
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10.2 Detailed information
The documentation listed in the following table offers additional information relevant to the SI6
drive controller. Current document versions can be found at 
http://www.stoeber.de/en/download.

Device/Software Documentation Contents ID

Multi-axis drive system
with SI6 and PS6

Manual System setup, technical data,
storage, installation, connection,
commissioning, operation,
service, diagnostics

442728

Multi-axis drive system
with SI6 and PS6

Commissioning
instructions

System setup, technical data,
storage, installation, connection,
commissioning

442731

EtherCAT communication Manual Installation, electrical installation,
data transfer, commissioning,
detailed information

443025

Additional information and sources that form the basis of this documentation or are referenced
by the documentation:

Beckhoff Automation GmbH & Co. KG (publisher): EtherCAT System Documentation. Version
5.1. Verl, 2016.

The TwinCAT 2 automation software is available for free at 
https://www.beckhoff.de/default.asp?download/tc2-download.htm.

The TwinCAT 3 automation software is available for free at 
https://www.beckhoff.de/default.asp?download/tc3-downloads.htm.

EtherCAT Technology Group (ETG), 2012. ETG.1300 : EtherCAT Indicator and Labeling.
ETG.1300 S (R) V1.1.0. Specification. 2012-01-27.

EtherCAT Technology Group (ETG), 2016. ETG.5001: Modular Device Profile, Part 4: Safety
Modules Specification. ETG.5001.4 S (D) V0.2.1. Specification. 2016-08-05.

EtherCAT Technology Group (ETG), 2016. ETG.6100: Safety Drive Profile, Part 1: Overview,
Scope. ETG.6100.1 S (R) V1.2.0. Specification. 2016-02-08.

EtherCAT Technology Group (ETG), 2016. ETG.6100: Safety Drive Profile, Part 2: Generic
Safety Drive Profile for adjustable speed electrical power drive systems that are suitable for use
in safety-related applications PDS(SR). ETG.6100.2 S (R) V1.2.0. Specification. 2016-02-08.

EtherCAT Technology Group (ETG), 2016. ETG.6100: Safety Drive Profile Part 3: Mapping to
Safety-over-EtherCAT. ETG.6100.3 S (WD) V1.2.0. Specification. 2016-02-08.

http://www.stoeber.de/en/download
https://www.beckhoff.de/default.asp?download/tc2-download.htm
https://www.beckhoff.de/default.asp?download/tc3-downloads.htm
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10.3 Abbreviations

Abbreviation Meaning

EMC Electromagnetic compatibility

ESI EtherCAT Slave Information

ETG EtherCAT Technology Group

EtherCAT Ethernet for Control Automation Technology

FSoE Fail Safe over EtherCAT

IGBT Insulated Gate Bipolar Transistor

I/O Input/Output

PDO Process Data Objects

PDS(SR) Power Drive System(Safety Related)

PL Performance Level

PWM Pulse Width Modulation

RxPDO Received PDO

SIL Safety Integrity Level

SIL CL Safety Integrity Level Claim Limit

PLC Programmable logic controller

SRECS Safety-Related Electrical Control System

SRP/CS Safety-Related Part of a Control System

SS1 Safe Stop 1

SS1-t Safe Stop 1-time

STO Safe Torque Off

TwinCAT The Windows Control and Automation Technology

TxPDO Transmitted PDO
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11 Contact

11.1 Consultation, service and address
We would be happy to help you!

We offer a wealth of information and services to go with our products on our website:
http://www.stoeber.de/en/service

For additional or personalized information, contact our consultation and support service: 
http://www.stoeber.de/en/support

Do you need our first-level support?: 
Phone +49 7231 582-3060 
applications@stoeber.de

Call our 24-hour service hotline:
Phone +49 7231 582-3000

Our address: 
STÖBER ANTRIEBSTECHNIK GmbH & Co. KG 
Kieselbronner Strasse 12 
75177 Pforzheim, Germany

11.2 Your opinion is important to us
We created this documentation to the best of our knowledge with the goal of helping you build
and expand your expertise productively and efficiently with our products.

You suggestions, opinions, wishes and constructive criticism help us to ensure and improve the
quality of our documentation.
If you would like to contact us for a specific reason, we would be happy to receive an e-mail
from you at:
documentation@stoeber.de

Thank you for your interest.
Your STOBER editorial team

http://www.stoeber.de/en/service
http://www.stoeber.de/en/support
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11.3 Close to customers around the world
We offer you committed, expert advise and support in over 40 countries worldwide:

STOBER AUSTRIA 
www.stoeber.at
Phone +43 7613 7600-0
sales@stoeber.at

STOBER SOUTH EAST ASIA 
www.stober.sg
Phone +65 65112912
sales@stober.sg

STOBER CHINA 
www.stoeber.cn 
Phone +86 10 6590 7391 
sales@stoeber.cn

STOBER SWITZERLAND 
www.stoeber.ch 
Phone +41 56 496 96 50 
sales@stoeber.ch

STOBER FRANCE 
www.stober.fr 
Phone +33 4 78.98.91.80 
sales@stober.fr

STOBER TAIWAN 
www.stober.tw 
Phone +886 4 2358 6089 
sales@stober.tw

STOBER ITALY 
www.stober.it 
Phone +39 02 93909570 
sales@stober.it

STOBER TURKEY 
www.stober.com 
Phone +90 212 338 8014 
sales-turkey@stober.com

STOBER JAPAN 
www.stober.co.jp 
Phone +81 3 5395 678 8 
sales@stober.co.jp

STOBER UNITED KINGDOM 
www.stober.co.uk 
Phone +44 1543 458 858 
sales@stober.co.uk

STOBER USA 
www.stober.com 
Phone +1 606 759 5090 
sales@stober.com
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Glossary
Black channel principle

Technology that allows secure data to be transmitted over unsecure network or bus lines.
Safety components can transmit safety-related data regardless of hardware using a secure
protocol that tunnels through the underlying network channel. Possible transmission errors
are noted in the standards IEC 61784-3 and IEC 61508.

Category

In accordance with DIN EN ISO 13849-1: Classification of safety-related parts of a controller
regarding their resistance against faults and their subsequent behavior in the event of fault.
A category is attained through the structure and the arrangement of parts, their fault
detection and/or their reliability. Possible category designations, i.e. classifications, are B, 1,
2, 3, 4.

ESI file

Device description file for EtherCAT slaves. In accordance with ETG.2000: XML file that
contains all relevant data for an EtherCAT-connected device in the EtherCAT system, such
as the identity of the manufacturer, the product code, the version or the serial number. 
The EtherCAT master requires this file to configure the EtherCAT system.

Fail Safe over EtherCAT (FSoE)

Protocol to transfer safety-relevant data via EtherCAT using a FSoE master and an
indefinite number of FSoE slaved (i.e. devices that have a Safety over EtherCAT interface).
The protocol therefore enables the realization of functional safety via EtherCAT. FSoE and
its implementation are TÜV-certified and comply with the SIL 3 requirements according to
IEC 61508.

FSoE address

Each FSoE slave has an address that provides unique identification for it in the FSoE
network. The address is generally configured at the device itself, such as using a DIP
switch. In a FSoE system, a maximum of 65534 (16 bits, 0 address is prohibited) devices
can be differentiated by their addresses.

Insulated Gate Bipolar Transistor (IGBT)

Bipolar transistor with insulated gate electrode. Four-layer semiconductor component that is
controlled using a gate and combines the advantages of a bipolar and field-effect transistor.
An IGBT is primarily used in power electronics.
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Length of use (TM)

In accordance with DIN EN 61800-5-2: Determined cumulative length of operation of the
PDS(SR) during its total life span.

Performance Level (PL)

Dimension for the reliability of a safety function or a component according to DIN EN
13849-1. The performance level is rated on a scale of a – e (lowest – highest PL). The
higher the PL, the safer and more reliable the function considered.

Probability of a failure per hour (PFH)

In accordance with DIN EN 61508/DIN EN 62061: Probability of device failure per hour.
Together with PFD, PFH is one of the most important bases for calculating the reliability of
the safety function of devices, the SIL.

Safe Stop 1 (SS1)

As per DIN EN 61800-5-2: procedure to stop a PDS(SR). For the safety function SS1, the
PDS(SR) performs one of the following functions: 
a) Initiation and control of the size of the motor delay within defined limits and triggering the
STO function when the motor speed drops below a defined limit value, or 
b) Initiation and monitoring of the size of the motor delay within defined limits and initiation
of the STO function when the motor speed drops below a limit value, or 
c) initiation of the motor delay and initiation of the STO function after an application-specific
time delay. SS1 corresponds to the controlled stop according to IEC 60204-1 stop 
category 1.

Safe Torque Off (STO)

Safety function that immediately interrupts the energy supply to the drive and stops the drive
in an uncontrolled manner. It can no longer generate torque after shutdown. STO is the
most basic drive-integrated safety function. It corresponds to stop category 0 according to
IEC 60204-1.

Safety Integrity Level (SIL)

In accordance with DIN EN 61800-5-2: Probability of safety function failure. SIL is divided
into levels 1 – 4 (lowest – highest level). SIL precisely assesses systems or subsystems
based on the reliability of their safety functions. The higher the SIL, the safer and more
reliable the function in question is.

Safety Integrity Level Claim Limit (SIL CL)

Maximum SIL that can be claimed, related to the structural limitations and systematized
safety integrity of a SRECS subsystem. A SIL CL is determined by the hardware fault
tolerance (HFT) and the proportion of safe failures of the subsystems (SFF).
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STO switch-off time

Timespan starting with the arrival of a FSoE telegram at the EtherCAT connection of the
drive controller with the command to activate the safety function up to the safe switch-off of
the power unit of the drive controller.

Worst case response time

Maximum time span required in order to switch off the actuator in the event of an error.
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